Əsas səhifə > MySQL > Installing MariaDB 10.0.2 on Ubuntu 12.04

Installing MariaDB 10.0.2 on Ubuntu 12.04

Rəsmi səhifədə göstərilən guide-a uyğun olaraq Mariadb-ni install etməyə çalışdım lakin alınmadı. Həll etdim və addım-addım indi burda qeyd edirəm(step-by-step). Onu da qeyd edək ki, 10.0.2 Alpha versiyadır yəni production-da istifadə etmək olmaz.Rəsmi saytda da bu qeyd olunub:
Do not use alpha releases on production systems.

sudo apt-get install python-software-properties
sudo apt-key adv --recv-keys --keyserver keyserver.ubuntu.com 0xcbcb082a1bb943db
sudo add-apt-repository 'deb http://repo.maxindo.net.id/mariadb/repo/10.0/ubuntu precise main'

Daha sonra:

sudo apt-get update
sudo apt-get install mariadb-server

Lakin aşağıdakı error gəlir və install getmir:

The following packages have unmet dependencies:
 mariadb-server : Depends: mariadb-server-10.0 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Həlli:

sudo apt-get install libmysqlclient18=10.0.2+maria-1~precise
.
.
The following extra packages will be installed:
  libmariadbclient18 mariadb-common mysql-common
.
.
Processing triggers for install-info ...
Setting up mysql-common (10.0.2+maria-1~precise) ...
Setting up mariadb-common (10.0.2+maria-1~precise) ...
Setting up libmysqlclient18 (10.0.2+maria-1~precise) ...
Setting up libmariadbclient18 (10.0.2+maria-1~precise) ...

Və daha sonra bir daha:

sudo apt-get install mariadb-server
.
.
The following extra packages will be installed:
  mariadb-client-10.0 mariadb-client-core-10.0 mariadb-server-10.0
  mariadb-server-core-10.0
.
.
* Starting MariaDB database server mysqld                               [ OK ] 
 * Checking for corrupt, not cleanly closed and upgrade needing tables.
Setting up mariadb-server (10.0.2+maria-1~precise) ...

Yoxlayırıq:

root@sh-ubuntu:~# mysql --version
mysql  Ver 15.1 Distrib 10.0.2-MariaDB, for debian-linux-gnu (x86_64) using readline 5.1

root@sh-ubuntu:~# mysql -u root -p
Enter password: 
Welcome to the MariaDB monitor.  Commands end with ; or \g.
Your MariaDB connection id is 40
Server version: 10.0.2-MariaDB-1~precise-log mariadb.org binary distribution

Copyright (c) 2000, 2013, Oracle, Monty Program Ab and others.

Bu qədər. Təşəkkürlər😉

  1. Hələlik heç bir şərh yoxdur
  1. No trackbacks yet.

Bir cavab yazın

Sistemə daxil olmaq üçün məlumatlarınızı daxil edin və ya ikonlardan birinə tıklayın:

WordPress.com Loqosu

WordPress.com hesabınızdan istifadə edərək şərh edirsinz. Çıxış / Dəyişdir )

Twitter rəsmi

Twitter hesabınızdan istifadə edərək şərh edirsinz. Çıxış / Dəyişdir )

Facebook fotosu

Facebook hesabınızdan istifadə edərək şərh edirsinz. Çıxış / Dəyişdir )

Google+ foto

Google+ hesabınızdan istifadə edərək şərh edirsinz. Çıxış / Dəyişdir )

%s qoşulma

%d bloqqer bunu bəyənir: